Altapay - MobilePay processing – Incident details

MobilePay processing

Resolved
Degraded performance
Started over 2 years agoLasted about 2 hours

Affected

Processing

Operational from 5:35 PM to 5:35 PM, Degraded performance from 5:35 PM to 8:01 PM

Updates
  • Update
    Update

    **Impact:** 1 - Low‌ **Description & Scope of incident** Some MobilePay transactions were internally declined when the card was tokenized and the acquirer was Finaro/Crederox. **Analysis of Incident** At 14:01 Some MobilePay transactions started to be marked with incorrect card scheme \(instead of MasterCard/Visa they were marked as ‘Unknown Card’\), but still processed 16:00 the underlying issue was identified 19:00 Monitoring systems indicated that some transactions were declined due to incorrect card scheme information 20:30 A fix was deployed to production which set correct card scheme information to new transactions ‌ **Remedial Action** 16/1-2023 All processed transactions with incorrect card type was updated to have proper card scheme information Mitigation plan: * Implemented additional checks/tests for serialization on MobilePay payload

  • Resolved
    Resolved

    This incident has been resolved

  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the situation

  • Identified
    Identified

    The issue has been identified and a fix is being implemented.

  • Investigating
    Investigating

    We are currently experiencing issues with MobilePay transactions. We are currently working on a solution.