Altapay - payment processing – Incident details

payment processing

Resolved
Degraded performance
Started over 3 years agoLasted 22 minutes

Affected

Processing

Operational from 4:06 PM to 4:06 PM, Degraded performance from 4:06 PM to 4:27 PM

Search service

Operational from 4:06 PM to 4:06 PM, Degraded performance from 4:06 PM to 4:27 PM

Updates
  • Update
    Update

    **Scope of Incident:** The automatic monitoring system reported lots of failed transactions which indicated a possible payment processing issue to be investigated ‌ **Analysis of incident:** Upon investigation it turned out that a few 3DS pages were sending hundreds of events per second which resulted in degraded performance on the reporting database. In general payments were processed as expected apart from a very limited number of transactions experiencing the issue with 3DS. ‌ Remedial Action: Several corrections were deployed to prevent this from happening again. * Limit number of failed events per transaction * Server side we only write one event to logging per transaction Further actions to improve queue processing logic will be implemented so timeout items will be placed in a separate queue to prevent possible blocking of regular payment processing.

  • Resolved
    Resolved

    A fix has been implemented and we are monitoring the systems

  • Update
    Update

    After further investigation we can see that payments are being processed as expected. The status of the payments are not being updated on the payment gateway so we will continue to investigate to find the underlying issue. Once again we see that payments are being processed as expected.

  • Investigating
    Investigating

    We are currently investigating a possible issue processing payments.