Scheduled for March 17, 2026 at 8:00 AM – 8:10 AM
Affects
Search service
Under maintenance from 8:00 AM to 8:10 AM
Completed
March 17, 2026 at 8:10 AMCompleted
March 17, 2026 at 8:10 AMMaintenance has completed successfully
In progress
March 17, 2026 at 8:00 AMIn progress
March 17, 2026 at 8:00 AMMaintenance is now in progress
Planned
March 17, 2026 at 8:00 AMPlanned
March 17, 2026 at 8:00 AMTo quickly address an unexpected issue and uphold our high standards of service, AltaPay will be performing emergency maintenance on our VPN
Our team has identified a need for immediate intervention to maintain system stability and prevent potential disruptions. We are moving swiftly and carefully to resolve the issue with minimal customer impact.
A brief period of reduced availability of the search service may occur during this time, and we’re doing everything possible to keep it short and controlled.
Please note that transactions will be processed without any impact and that it is only related to search/lookup of transactions which is affected.
Thank you for your understanding and continued trust in AltaPay.