Altapay - Performance Issues with Mastercard 3D Secure (3DS) – Incident details

Performance Issues with Mastercard 3D Secure (3DS)

Resolved
Major outage
Started 7 days agoLasted about 3 hours
Updates
  • Resolved
    UTC
    Resolved

    The issues affecting the Mastercard 3D Secure (3DS) service seem to have been fully resolved. Based on our monitoring the Mastercard transaction processing has returned to normal.

  • Monitoring
    UTC
    Monitoring

    We are now seeing signs of recovery with the Mastercard 3D Secure (3DS) service. Mastercard transaction processing is beginning to return to normal, but we continue to monitor the situation.

  • Identified
    UTC
    Identified

    We are currently receiving reports of issues affecting the Mastercard 3D Secure (3DS) authentication service. This external issue may negatively impact your Mastercard transaction processing, leading to increased timeouts or failed authentications.

    Our team is monitoring the situation.